No Joy on In-place Upgrade; Clean Install Succeeds

I’d been hoping to try an upgrade install on my balky, problem-prone production PC to see if it could cure or at least help to address some of the issues that Vista has developed over time in that runtime environment. Alas, it was not to be. I’ll share the details in the next paragraphs, but for now I can only report that a strange and possibly spurious leftover from Trend Micro Internet Security 2008 stymied my in-place upgrade attempts. All contortions to remove its traces failed, and the upgrade utility wouldn’t let an upgrade proceed, so I performed a clean install instead. Overall results from that maneuver are 98% positive, as I will also report later in this blog as well. On to the (failed) in-place upgrade attempt.

Attempting In-Place Upgrade

On my initial attempt to run an upgrade install from Vista to Windows 7 Ultimate on my production machine, the first run produced the following list of applications that had to be uninstalled for the process to proceed:

  1. Intellitype and/or Intellipoint: With an MS Comfort Curve 4000 keyboard installed I had the former, so it was removed without incident. Close examination also showed the presence of Intellipoint as well, so it was removed as well. I used Revo Uninstaller throughout to clean up lingering files and registry traces after the built-in uninstall utility completed; both programs uninstalled themselves without leaving any lingering traces.
  2. Daemon Tools Lite: I used this to mount ISO images as virtual file systems on my PC, now that I’ve been downloading them regularly from MSDN (and having also grabbed some from BitTorrent during my work on a recent Windows 7 book). Interestingly, neither the Programs and Features item in Control Panel nor Revo Uninstaller sees this application. Fortunately, the built-in uninstaller worked to Microsoft’s satisfaction.
  3. Trend Micro Internet Security 2008 (TMIS08): Not installed on my PC, and I have no memory of ever having done so on this machine. Just to be safe, I uninstalled the two Trend Micro products I did have installed on this machine — namely, Hijack This! and Housecall, using Revo Uninstaller. No lingering traces for either item reported by that program. [Update on 8/14/09: On the phone with Rebekkah Hilgraves earlier this week she reminded me that I had indeed installed this software on my PC last year in connection with work for Digital Landing. It had been long since removed, with no obvious traces of its presence, but something must have been left behind.]

Alas, my next attempt to perform the in-place upgrade still failed, and reported that TMIS08 still needed to go. I searched my system drive for Trend Micro files and directories, found none. I searched and removed all Trend Micro references from my registry, ran CCleaner, rebooted, then tried again. No joy. Thinking it might be my current AV/anti-spyware package causing a false report, I uninstalled Spyware Doctor with Antivirus and tried again. Still no joy. I searched the Web for instructions on uninstalling TMIS08 and made sure I’d covered all the bases (I had, and even the MS Install Clean-up Tool reported no traces of this program on my system) and decided to give up and perform a clean install instead. I have to believe this was the proper course of action anyway, given the numerous problems I’ve been fighting in Vista on this machine. Though I wasn’t able to satisfy my perverse curiosity, I do think this was the the right thing to do anyway.

Performing a Clean Install

After spending about four hours trying to make the in-place upgrade work, it took less than half an hour to perform the clean install. After that, it took about an hour to get all of the Windows Updates items installed, including a quick install and post-install cleanup to get MS Office 2007 Enterprise Edition up and running. The updates brought in  new drivers for ACPI and my motherboard’s built-in RealTek GbE Ethernet adapter. Following that maneuver I installed the DriverAgent drive scanner to assess how Windows 7 did in supplying drivers for my motherboard, and had to install the latest Logitech SetPoint 4.80 version (out last Wednesday, 8/5),  a driver for my second monitor, a Dell 1905FP that showed up as a “Generic PnP Monitor” instead, and update the drivers for my Dell AIO 968 inkjet all-in-one unit. Not too shabby an experience, all-in-all —if anything, even better than what I experienced on half-a-dozen PCs (2 desktops, 4 notebooks) while working with the beta Windows 7 versions from Build 7000 through Build 7100 (the RC).

After that, I installed a pretty lengthy list of applications to re-create the everyday work environment on my production PC (but left everything not absolutely necessary, trimming total count from over 100 to 43 including system and driver related components listed in Revo Uninstaller):

Production PC Applications and Miscellany
Freeware Remarks Commercial SW Remarks
Driveragent Driver currency check MS Office Enterprise 2007 Standard productivity suite
FileZilla FTP client PC Doctor w/Antivirus Favorite AV/antispyware pkg
HP USB Format Tool Builds bootable UFDs Acronis TrueImage Home 2009 Use this for occasional image backups
Secunia PSI Software update monitor Corel PSP X2 Budget image editor for pix and screencaps
WinDirStat Visual disk space mapper HP MediaSmart Tools Client SW for HP MediaSmart Server
ISO Recorder Excellent ISO burning tool WinZip 12.1 Still my favorite file compression toolkit
Logitech SitePoint 4.80 Mouse driver and mgmt tool WAIK for Windows 7 For building minimal book/repair images
Firefox Alternative mainstay browser More Freeware More Remarks
Adobe Reader PDF reader Adobe Flash Flash players for IE and Firefox
Piriform CCleaner Registry and file clean-up tool Revo Uninstaller App uninstaller and clean-up tool
Skype VoIP and IM program Intel Matrix Storage Mgr 47 Manages mirrored boot/system disks
MS Intellitype 7.0 Keyboard mgmt app Dell AIO 968 tools AIO setup, mgmt, and misc tools

Total time expended for everything, including installing and minor OS tweaks (set up ReadyBoost, tweak Folder Options, configure e-mail accounts, and so forth) and installing all of the drivers and apps was about 12 hours. This is at least four hours shorter than my last major Vista rebuild, and I account for the the time difference thanks to Windows 7’s faster install time (1 hour for Vista versus half an hour for Windows 7) and an easier time with drivers and post-install set-up than with Vista (lots more updates to slipstream on an older operating system, to be sure).

What’s My Status?

My previous Vista issues have all but disappeared (see …Vista Mysteries for details): Sidebar and Event Viewer are working normally, there are no strange networking connectivity issues or spurious reports of same, and there are no dwm.exe or explorer.exe failures to report just yet. The HP MediaSmart connector and other software is functioning perfectly, and I’m once again able to interact with the MediaSmart Server as I should be. In short, all of my software mysteries have indeed been fixed. [Update on 8/14/09: I’m having WHS Connector problems on another Windows 7 machine, and thought I was having similar problems on the production machine as well, but they proved related to a failing D: drive gave up the ghost yesterday morning–though recovery took time, I was incredibly thankful to have a current backup).]

But all is not peaches and cream, either. I still have some issues with the memory card reader integrated into my Dell 2707 WFP monitor. Its USB hub works just fine now, and I can interact with SD cards, but the Compact Flash reader doesn’t appear to be working (and probably accounts for the Unknown Device warning that DriverAgent reports but that Device Manager does not). I do still have some USB issues on the system, but I’m increasingly inclined to suspect balky, damaged, or failing hardware (I bent the USB connector on the Corsair UFD that I now use for ReadyBoost — it’s my fastest flash drive —and I believe there’s an internal short or connection failure on the 2707’s CF memory card reader) for such problems as remain. But because I have a built-in card reader on the Dell AIO that works just fine, and even a plug-in CF-to-USB adapter, I’m not too concerned about the 2707 issue, particularly because my second monitor covers up those connectors anyway.

So far, I can live quite nicely with my current situation, and I see almost none of the disturbing signs of system instability under Windows 7 that I saw every day under Vista. My only current problem is that the video on my primary 2707 monitor goes black for a couple of seconds three or four times a day, with obvious signs of video driver issues (I’m running an Nvidia GeForce GTX 275 with driver version 8.15.11.8635 [Update on 8/14/09: yesterday MS provided a new, Windows 7 labeled Nvidia driver via Windows Update which I installed immediately; now, I’m done to one brief daily blackout). I’ll wait for more usage history to be reported online and may roll back to an earlier version if that shows signs of easing my plight.

Time will tell, as it always does with Windows, including this latest version. All in all, I’m much happier with Windows 7 on this production unit than I was with Vista. So far, my intuition that this would be the case is holding out pretty well, but I’m not inclined to declare victory until I have more time in the Windows 7 harness and can see how things go on a day-in, day-out basis. Going forward, though, I will be limiting my experimental installs of new or test software to virtual machines, and trying to limit the amount of gunking up that I allow on this newly rebuilt Windows image. I have to see that as a potential and likely cause of my earlier Vista woes on this system.

Advertisements

One Trackback/Pingback

  1. […] See more here: No Joy on In-place Upgrade; Clean Install Succeeds « Viz Vista by … […]

Post a Comment

You must be logged in to post a comment.
%d bloggers like this: